Makerbot Thing-O-Matic

From VoidWarranties - Hackerspace Antwerp, Belgium
(Difference between revisions)
Jump to: navigation, search
m
(5th April 2014 (Iceroyale))
 
(10 intermediate revisions by 4 users not shown)
Line 4: Line 4:
 
|Logo=IMG 2876.jpg  
 
|Logo=IMG 2876.jpg  
 
|Participants=Yashiko, Oddly
 
|Participants=Yashiko, Oddly
|Locations=Den Bunker,
+
|Locations=VoidWarranties
 
|Short description=3D printer
 
|Short description=3D printer
 
}}
 
}}
Line 38: Line 38:
  
 
==Printing a testmodel==
 
==Printing a testmodel==
*File > Examples > 20 mm calibrationbox stl
+
* File > Examples > 20 mm calibrationbox stl
you'll see the model  
+
* You will see a 3D representation of the model
*GCode > Generate > /usr/bin/python2 > Ok
+
* GCode > Generate > /usr/bin/python2 > Ok
*the settings: do not touch until we figured the optimal settings
+
* The settings: do not touch until we figured the optimal settings
 
**Plastic: 1,82mm
 
**Plastic: 1,82mm
 
**Extruder 0,4mm
 
**Extruder 0,4mm
**Extruder temperature: 230C (It appears that the temperature safety switch for the extruderhead gets tripped sometimes on this temperature, the extruder stops extruding and starts to cool down), we'll try it on 220 next time (3/6/2013)
+
**Extruder temperature: 220C (It appears that the temperature safety switch for the extruderhead gets tripped sometimes on higher temperatures, the extruder stops extruding and starts to cool down)
 
+
 
*Generate
 
*Generate
now the different steps will be shown, you can see the different layers click buttons on the bottom of the page
 
now wait....................
 
here's your gcode
 
 
*GCode > Build (Ctrl+B)
 
*GCode > Build (Ctrl+B)
 
*The machine will first heat up and then start building automatically
 
*The machine will first heat up and then start building automatically
  
 
=Progress Log=
 
=Progress Log=
*gcode> gcode generator> skeinforge (47) works much better then skeinforge (50). Printing results are much smoother and nicer (3/6/2013)
+
===Mon 3th June 2013===
 +
*Gcode> gcode generator> skeinforge (47) works much better then skeinforge (50). Printing results are much smoother and nicer (3/6/2013)
 
*Regulary clean the extruder head with a fine sandpaper to remove the build up and burned abs.
 
*Regulary clean the extruder head with a fine sandpaper to remove the build up and burned abs.
  
=== Di 4 Juni ===
+
=== Tue 4th June 2013===
 
As we came out of hyperspace with spaceship Thing-O-Matic we immediately began with the upgrade of the Arduino Mega 2560 inside.
 
As we came out of hyperspace with spaceship Thing-O-Matic we immediately began with the upgrade of the Arduino Mega 2560 inside.
  
 
Our findings:
 
Our findings:
* Updated the firmware of the Thing-O-Matic from Marlin 3.1 to Sailfish 4.4(support for accelerated en 5D printing. After this, I updated ReplicatorG to 0040.
+
* Updated the firmware of the Thing-O-Matic from Marlin 3.1 to Sailfish 4.4(support for accelerated en 5D printing. After this, I updated ReplicatorG to 0040. We now use code generator skeinforge (50), it works good with Sailfish 4.4. We can also print much faster now(using accelerated printing).
  We now use code generator skeinforge (50), it works good with this firmware. We can also print much faster now.
+
 
* Played a little bit with the settings, the printer head kept touching the printed piece while printing. This was because of the small dent in the middle of the board. Calibrating the Z axis a bit out of the middle of the board, gave very nice and smooth print results. Please don't change and save the settings, the "default Thing-O-Matic" slice settings in ReplicatorG should work. If you do want to test with changing settings, duplicate the profile and rename it to "Test" or "yournamehere".
 
* Played a little bit with the settings, the printer head kept touching the printed piece while printing. This was because of the small dent in the middle of the board. Calibrating the Z axis a bit out of the middle of the board, gave very nice and smooth print results. Please don't change and save the settings, the "default Thing-O-Matic" slice settings in ReplicatorG should work. If you do want to test with changing settings, duplicate the profile and rename it to "Test" or "yournamehere".
 
* Started to print a upgrade for the Thing-O-Matic: a snap-on table, adjustable in height with screws. The board is snap-on, snap-off with magnets for easy maintenance(no magnets acquired yet though).
 
* Started to print a upgrade for the Thing-O-Matic: a snap-on table, adjustable in height with screws. The board is snap-on, snap-off with magnets for easy maintenance(no magnets acquired yet though).
Line 69: Line 65:
 
** Slow down your printing feed rate to 30-40mm/min, it will take much longer to print, but your print will less likely be ruined.
 
** Slow down your printing feed rate to 30-40mm/min, it will take much longer to print, but your print will less likely be ruined.
 
** Clean the table with a kitchen paper and acetone.
 
** Clean the table with a kitchen paper and acetone.
** Increase raft size, in width, in thickness and/or full fill. This is a advanced option, please use another profile(testing or your name) to adjust these settings. Oddly can assist you with this.
+
** Increase raft size, in width, in thickness and/or full fill. This is an advanced option, please use another profile(testing or your name) to adjust these settings. Oddly can assist you with this.
 
** Increase table temperature to 115-120C, maximum 130C.
 
** Increase table temperature to 115-120C, maximum 130C.
** Replace the Kapton tape, it could have been worn out
+
** Replace the Kapton tape, it could be worn out
 +
 
 +
===Sun 23th june 2013 (berz_)===
 +
* Tried to print something, but after a while I started to lose steps on the X axis. This was also the case when manually controlling the printer to replicator G.
 +
* I found out the gear attached to the X axis motor shaft had become loose.
 +
* to tighten it I had to take out the Y axis and open up the X assembly partially to reach the X motor shaft with a small Allan key.
 +
* After the gear was firmly reattached to the shaft the printer printed smoothly.
 +
 
 +
===(Oddly)===
 +
* When printing, noticed that the printer was losing steps in the Y axis. The belt was loose, so I tightened it, which was really hard because the motor couldn't be pulled back far enough. Eventually managed to tighten the belt enough with some magic.
 +
* Printed some "gears" to balance the table, we still have to finish and attach them.
 +
* Tested the new "Makerware" software, it has some improvements in the back end (some custom skeinforge perhaps?), but the settings in the program are very limited. Good for when you are new to 3D printing.
 +
 
 +
===Sat 29th june 2013 (Yashiko)===
 +
* Oddly had pulled of the kapton tape and aluminium foil of the heated bed a couple of days ago.
 +
** This was because the kapton tape was damaged and was creating bubbles, printing without kapton tape resulted in the piece coming loose during the print.
 +
** I replaced the kapton tape but not the foil. I wanna see if there is a difference in heat distribution on the bed.
 +
** This time I folded the tape over the edges to see if it stays in place longer and better.
 +
 
 +
* I replaced the broken fan that cools down the printerhead. (I broke one blade myself, so only just that I replaced it)
 +
 
 +
I did some testing with a new filament: laybrick.
 +
* We got a package to test it out at the local 3D Hubs meeting yesterday.
 +
TEST 1:
 +
* Settings:
 +
**Temp. Stepstrude: 200ºC
 +
**Object fill: 25%
 +
**Layer height: 0,2
 +
**Number of shells: 4
 +
**Feedrate: 30
 +
**Travel feedrate: 50
 +
**Filament diameter: 1,80
 +
**Extruder: 0,4
 +
**Platform temp.: 100ºC
 +
**With a raft
 +
TEST 2:
 +
*Settings:
 +
**Temp. Stepstruder: 180ºC
 +
**Layer height: 0,3
 +
**Filament diameter: 1,60
 +
**The rest of the settings are the same as in test 1
 +
TEST 3:
 +
*Settings:
 +
**Extruder: 0,5
 +
**Filament diameter: 1,60
 +
**Number of shells: 1
 +
**Temp. Stepstruder:180ºC
 +
**Platform temp.: 50ºC
 +
**Layer height: 0.2
 +
**Object fill: 25%
 +
**Feedrate: 30
 +
**Travel feedrate: 50
 +
**Without a raft
 +
*TEST 4:
 +
*Settings:
 +
**Calibrated the Z-axis a bit higher as the point zero.
 +
**Platform temp.: 100ºC
 +
**The rest of the settings are the same as in test 3.
 +
*I took the piece to soon from the platform. It got a bit deformed by it.
 +
TEST 5:
 +
*Settings:
 +
**Feedrate: 25
 +
**Platform temp: 50ºC
 +
**Calibrated the Z-axis a bit lower again, but still higher then test 3.
 +
** with a raft
 +
**The rest of the settings are the same as in test 3.
 +
TEST 6:
 +
*Settings:
 +
**Platform temp.: 75ºC
 +
**Fine tuned the Z-axis a little more. A bit lower.
 +
**Without a raft
 +
**The rest of the settings are the same as in test 5.
 +
TEST 7 & 8:
 +
*Settings:
 +
**Fine tuned the Z-axis a little more. A bit lower.
 +
**The rest of the settings are the same as in test 6.
 +
TEST 9: Final test.
 +
* Settings:
 +
**Temp. Stepstrude: 180ºC
 +
**Object fill: 25%
 +
**Layer height: 0,2
 +
**Number of shells: 1
 +
**Feedrate: 25
 +
**Travel feedrate: 50
 +
**Filament diameter: 1,60
 +
**Extruder: 0,5
 +
**Platform temp.: 75ºC
 +
**Without a raft
 +
**Fine tuned the Z-axis even a little more. A bit lower.
 +
 
 +
=== 5th April 2014 (Iceroyale) ===
 +
 
 +
*Model rendering did not work on Ubuntu, installed replicatorG on my win7 laptop, which worked.
 +
*early printing tests indicated zero position was being systematically reset by the Gscript.
 +
*Manually reset zero position and removed the "homing" section in the beginning of the Gscript, which prevented the resetting of zero position.
 +
*Printed two calibration blocks to finetune zero position
 +
*succesfully printed a dalek toothpick/salt shaker
 +
 
 +
=== 16th April 2014 (warddr) ===
 +
*Endstop was broken (cable cut). Fixed it.
  
 
=Cool Projects we made with Vettige Swa=
 
=Cool Projects we made with Vettige Swa=

Latest revision as of 22:19, 16 April 2014


Makerbot Thing-O-Matic
What:
3D printer
IMG 2876.jpg
Participants:
Yashiko, Oddly
Category:
Infrastructure
Locations:
VoidWarranties
IMG 2844.jpg

Thing-O-Matic instructions

Contents

Who is "Vettige Swa"

Building the printer

building instructions

How does this thing work

Turning it on

Calibration

This must be done every time you turn on the printer

Printing a testmodel

Progress Log

Mon 3th June 2013

Tue 4th June 2013

As we came out of hyperspace with spaceship Thing-O-Matic we immediately began with the upgrade of the Arduino Mega 2560 inside.

Our findings:

Sun 23th june 2013 (berz_)

(Oddly)

Sat 29th june 2013 (Yashiko)

I did some testing with a new filament: laybrick.

TEST 1:

TEST 2:

TEST 3:

TEST 5:

TEST 6:

TEST 7 & 8:

TEST 9: Final test.

5th April 2014 (Iceroyale)

16th April 2014 (warddr)

Cool Projects we made with Vettige Swa

Personal tools
Namespaces
Variants
Actions
Navigation
Toolbox
Content Creation
Belgian Spaces