Fixing the MiniCNC

From Voidwarranties - Hackerspace Antwerp, Belgium
(Difference between revisions)
Jump to: navigation, search
Line 15: Line 15:
  
 
* software is broken on current JRE on my x64 machine (Sun/1.7u21), need fixup for files before being able to continue.
 
* software is broken on current JRE on my x64 machine (Sun/1.7u21), need fixup for files before being able to continue.
 +
 +
=== Firmware ===
 +
 +
The device apparently needs a firmware update too. Added to the TODO list.
 +
 +
    ********************************************************
 +
    This version of ReplicatorG is not reccomended for use with firmware before version 3.0. Either update your firmware or proceed with caution.
 +
    ********************************************************
  
 
= Required materials for fixing and expected cost =
 
= Required materials for fixing and expected cost =

Revision as of 14:41, 4 May 2013


Fixing the MiniCNC
What:
Fixing the (broken) MiniCNC
Minicnc fixup.jpg
Participants:
Yvanj
Category:
Infrastructure
Locations:
Den Bunker

Contents

Diagnosis

Hardware

Software

Requires hugely out-of-date ReplicatorG version (25). Added porting the files to a more recent version to the TODO list since the older version depends on older Java components, which fuck up more recent systems and add an extra layer of insecurity to them.

Firmware

The device apparently needs a firmware update too. Added to the TODO list.

   ********************************************************
   This version of ReplicatorG is not reccomended for use with firmware before version 3.0. Either update your firmware or proceed with caution.
   ********************************************************

Required materials for fixing and expected cost

TBD

TODO

Personal tools
Namespaces
Variants
Actions
Navigation
Toolbox
Content Creation
Belgian Spaces